SOOXU博客手机版

华为交换机trunk配置

针对trunk配置我们很多人都有疑惑,所以我们针对华为交换机trunk配置这个问题SOOXU博客整理了2023年兔年最新实用的解释回答,接下来就给大家介绍一下,一起来看看吧。

eNSP模拟实验-交换机trunk配置

本文交换机间trunk配置,实现PC间相同VLAN可以访问。

交换机三种链路端口:

1:Access:只能属于1个VLAN,一般用于连接计算机端口(计算机和交换机)。

2:Trunk:可以允许多个VLAN通过,可以接收和发送多个VLAN的报文,一般用于交换机之间连接的端口。

3:Hybird:可以允许多个VLAN通过,可以接收和发送多个VLAN 报文,可以用于交换机的间连接也可以用于连接用户计算机。

可以在交换机运行port link-type ? 查看支持的端口类型。

[SW1-GigabitEthernet0/0/3]port link-type ?

  access        Access port

  dot1q-tunnel  QinQ port

  hybrid        Hybrid port

  trunk        Trunk port

dot1q-tunnel为二层vlan标识能够在wan上传递,即跨wan的vlan。

PC1:IP地址为192.168.1.10     子网掩码为255.255.255.0

PC2:IP地址为192.168.1.20     子网掩码为255.255.255.0

PC3:IP地址为192.168.1.30     子网掩码为255.255.255.0

PC4:IP地址为192.168.1.40     子网掩码为255.255.255.0

Huaweisystem-view 【进入系统模式】

[Huawei]undo info-center enable 【撤消信息中心启用】

[Huawei]vlan batch 10 20

[Huawei]interface GigabitEthernet 0/0/1

[Huawei-GigabitEthernet0/0/1]port link-type access【端口访问】

[Huawei-GigabitEthernet0/0/1]port default vlan 10

[Huawei-GigabitEthernet0/0/1]quit

[Huawei]interface gi 0/0/2

[Huawei-GigabitEthernet0/0/2]port link-type access

[Huawei-GigabitEthernet0/0/2]port default vlan 20

配置后PC1与PC2不能相互访问。

Huaweisystem-view 【进入系统模式】

[Huawei]undo info-center enable 【撤消信息中心启用】

[Huawei]vlan batch 10 20【创建VLAN】

[Huawei]interface GigabitEthernet 0/0/1【千兆位网接口】

[Huawei-GigabitEthernet0/0/1]port link-type access【端口访问】

[Huawei-GigabitEthernet0/0/1]port default vlan 20

[Huawei-GigabitEthernet0/0/1]quit

[Huawei]interface gi 0/0/2

[Huawei-GigabitEthernet0/0/2]port link-type access 

[Huawei-GigabitEthernet0/0/2]port default vlan 10

配置后PC3与PC4不能相互访问。

[Huawei]interface gi 0/0/3

[Huawei-port-group-link-type]port link-type trunk

[Huawei-port-group-link-type]port trunk allow-pass vlan 10 20

[Huawei]interface gi 0/0/3

[Huawei-port-group-link-type]port link-type trunk

[Huawei-port-group-link-type]port trunk allow-pass vlan 10 20

两个交换机相同配置,这时就可以实现PC1和PC3通,PC2和PC4通。在PC1上测试:

华为交换机trunk配置-图1

思科交换机配置trunk口

1、首先看一下拓扑图,我们可以看到两台交换机之间需要配置trunk才能实现不同交换机下的同一个vlan互相访问。

2、先配置PC0到PC6的IP地址。

3、查看交换机SW1的vlan配置SW1(config)#do sh vlan bri可以看到交换机SW1没有vlan配置。

4、创建vlan2SW1(config)#vlan 2命名为it,技术部。SW1(config-vlan)#name it创建vlan3SW1(config-vlan)#vlan 3命名为market,市场部。SW1(config-vlan)#name market。

5、划分fa0/1-2接口到vlan2SW1(config)#int range fa0/1-2设置access模式SW1(config-if-range)#swi mod accSW1(config-if-range)#swi acc vlan 2划分fa0/3-5接口到vlan3SW1(config-if-range)#int range fa0/3-5SW1(config-if-range)#swi mod accSW1(config-if-range)#swi acc vlan 3查看接口是否在vlan2和vlan3中,可以看到划分成功。

Huawei的交换机如何配置trunk?

【配置环境参数】\x0d\x0a1. SwitchA 端口E0/1属于vlan10,E0/2属于vlan20,E0/3与SwitchB端口E0/3互连\x0d\x0a2. SwitchB 端口E0/1属于vlan10,E0/2属于vlan20,E0/3与SwitchA端口E0/3互连\x0d\x0a【组网需求】\x0d\x0a1. 要求SwitchA的vlan10的PC与SwitchB的vlan10的PC互通\x0d\x0a2. 要求SwitchA的vlan20的PC与SwitchB的vlan20的PC互通\x0d\x0a【SwitchA相关配置】\x0d\x0a1. 创建(进入)VLAN10,将E0/1加入到VLAN10\x0d\x0a[SwitchA]vlan 10\x0d\x0a[SwitchA-vlan10]port Ethernet 0/1\x0d\x0a2. 创建(进入)VLAN20,将E0/2加入到VLAN20\x0d\x0a[SwitchA]vlan 20\x0d\x0a[SwitchA-vlan20]port Ethernet 0/2\x0d\x0a3. 配置端口e0/3 trunk端口,实际当中一般将上行端口设置成trunk属性\x0d\x0a[SwitchA-Ethernet0/3]port link-type trunk\x0d\x0a4.允许所有vlan通过,\x0d\x0a[SwitchA-Ethernet0/3]port trunk permit vlan all\x0d\x0a5.一般情况下最好指定端口允许通过哪些具体的VLAN,不要设置允许所有的VLAN通过\x0d\x0a例如:[SwitchA-Ethernet0/3]port hybrid vlan 10 20 untagged\x0d\x0a【SwitchB相关配置】\x0d\x0a1. 创建(进入)VLAN10,将E0/1加入到VLAN10\x0d\x0a[SwitchB]vlan 10\x0d\x0a[SwitchB-vlan10]port Ethernet 0/1\x0d\x0a2. 创建(进入)VLAN20,将E0/2加入到VLAN20\x0d\x0a[SwitchB]vlan 20\x0d\x0a[SwitchB-vlan20]port Ethernet 0/2\x0d\x0a3. 配置端口e0/3 trunk端口,实际当中一般将上行端口设置成trunk属性\x0d\x0a[SwitchB-Ethernet0/3]port link-type trunk\x0d\x0a4.允许所有vlan通过,\x0d\x0a[SwitchB-Ethernet0/3]port trunk permit vlan all\x0d\x0a5.一般情况下最好指定端口允许通过哪些具体的VLAN,不要设置允许所有的VLAN通过\x0d\x0a例如:[SwitchB-Ethernet0/3]port hybrid vlan 10 20 untagged\x0d\x0a\x0d\x0a23,24系列的交换机可能稍微有点出入,有出入的地方进了接口打问号,

交换机如何配置TRUNK口

不知道交换机如何配置TRUNK口的吗,那么交换机如何配置TRUNK口的呢?下面是我收集整理的交换机如何配置TRUNK口,希望对大家有帮助~~

交换机配置TRUNK口的方法

工具/原料

HCL云

Oracl VM VitrualBox

方法/步骤

打开HCL并搭建好拓扑图并启动设备(华三同思科一样默认交换机vlan 1)。如下图:

打开VMVirtualBox,配置IP地址(切记同一网段哦。)

回到HCL双击交换机,进入用户界面。试用system-view进入系统界面。创建VLAN 10(添加端口时一切信息以设备为基准),使用display current-configuration查看端口。然后添加端口port g1/0/1.第二台交换机的配置也是如此,在这里就不重复了。

   

打开VMVirtualBox,使用ping命令ping192.168.1.12,最终结果是ping不同的,因为还没有设置TRUNK口,默认只有VLAN 1才能通过。

接下来配置TRUNK口,命令如图

Cisco交换机Trunk配置命令是什么?

TRUNK(端口汇聚)是端口汇聚的意思,就是通过配置软件的设置,将2个或多个物理端口组合在一起成为一条逻辑的路径从而增加在交换机和网络节点之间的带宽,将属于这几个端口的带宽合并,给端口提供一个几倍于独立端口的独享的高带宽。

Trunk是一种封装技术,它是一条点到点的链路,链路的两端可以都是交换机,也可以是交换机和路由器,还可以是主机和交换机或路由器。

基于端口汇聚(Trunk)功能,允许交换机与交换机、交换机与路由器、主机与交换机或路由器之间通过两个或多个端口并行连接同时传输以提供更高带宽、更大吞吐量,大幅度提供整个网络能力。

在语音级应用的线路中,trunk一般指“主干网络、电话干线”,即两个交换局或交换机之间的连接电路或信道,它为两端设备之间进行转接,作为信令和终端设备数据的传输链路。

扩展资料

TRUNK功能具体应用

1、TRUNK功能用于与服务器相联,给服务器提供独享的高带宽。

2、TRUNK功能用于交换机之间的级联,通过牺牲端口数来给交换机之间的数据交换提供捆绑的高带宽,提高网络速度,突破网络瓶颈,进而大幅提高网络性能。

3、Trunk可以提供负载均衡能力以及系统容错。由于Trunk实时平衡各个交换机端口和服务器接口的流量,一旦某个端口出现故障,它会自动把故障端口从Trunk组中撤消,进而重新分配各个Trunk端口的流量,从而实现系统容错。

***:***-trunk

AI二次元绘画小程序内侧中 扫码免费体验

AI绘画小程序

本文内容摘抄自互联网如您觉得侵犯了您的权益,请发送邮件至 sooxu@vip.qq.com 反馈,本站将立刻删除!
转载请注明出处:https://www.sooxu.com/dianshang/113038.shtml

分享:
扫描分享到社交APP
x

注册

已经有帐号?